Qt SDK 安装错误 Gtk-CRITICAL **: IA__gtk_widget_style_get: assertion `GTK_IS_WIDGET (widget)’ failed

在 Ubuntu 上安装 Qt SDK,但是点击 Setting 时就会不停
弹出窗口,程序不响应了,终端上不断输出,
(Qt_SDK_Lin32_online_v1_2_en.run:4480): Gtk-CRITICAL **: IA__gtk_widget_style_get: assertion `GTK_IS_WIDGET (widget)’ failed
我是直接执行一下命令安装的
./Qt_SDK_Lin32_online_v1_2_en.run

然后改用
sudo ./Qt_SDK_Lin32_online_v1_2_en.run
发现没有问题出现

那么是什么原因导致那种错误发生呢,有没有其它的解决方法呢,
最后还是找到了
./Qt_SDK_Lin32_online_v1_2_en.run -style cleanlooks

参考:
https://bugs.launchpad.net/ubuntu/+source/qt4-x11/+bug/805303
http://qt-project.org/forums/viewthread/11247/

Post a Comment

Your email is never shared. Required fields are marked *

*
*